BETA

27th November 2024

West Bengal Issue observed for 'Outgoing Calls' in West Bengal Region

Identified at [27/11/24 12:17 PM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [27/11/24 12:45 PM]