Exotel Status Board
Home
Dashboard
BETA
14th November 2024
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [14/11/24 03:27 AM] with 'Major Outage'
Issue has been resolved at [14/11/24 03:30 AM]