Exotel Status Board
Home
Dashboard
BETA
13th November 2024
Andhra Pradesh
Issue observed for 'Incoming Calls' in Andhra Pradesh Region
Identified at [13/11/24 10:45 AM] with 'Major Outage'
Issue has been resolved at [13/11/24 10:57 AM]