Exotel Status Board
Home
Dashboard
BETA
9th November 2024
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [09/11/24 11:50 AM] with 'Major Outage'
Issue has been resolved at [09/11/24 06:42 PM]