Exotel Status Board
Home
Dashboard
BETA
8th November 2024
Mumbai
Issue observed for 'Incoming Calls' in Mumbai Region
Identified at [08/11/24 03:55 AM] with 'Major Outage'
Issue has been resolved at [08/11/24 04:20 AM]