BETA

29th October 2024

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [29/10/24 04:30 AM] with 'Partial Outage'

Issue has been resolved at [29/10/24 04:57 AM]