Exotel Status Board
Home
Dashboard
BETA
28th October 2024
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [28/10/24 03:35 AM] with 'Major Outage'
Issue has been resolved at [28/10/24 04:15 AM]