Exotel Status Board
Home
Dashboard
BETA
25th October 2024
Indonesia
Issue observed for 'Outgoing Calls' in Indonesia
Identified at [25/10/24 08:50 AM] with 'Major Outage'
Issue has been resolved at [25/10/24 09:00 AM]