Exotel Status Board
Home
Dashboard
BETA
18th October 2024
Chennai
Issue observed for 'Incoming Calls' in Chennai Region
Identified at [18/10/24 01:35 PM] with 'Major Outage'
Issue has been resolved at [18/10/24 01:40 PM]