BETA

8th July 2024

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [08/07/24 07:15 PM] with 'Major Outage'

Issue has been resolved at [08/07/24 07:20 PM]