BETA

6th July 2024

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [06/07/24 04:17 AM] with 'Partial Outage'

Issue has been resolved at [06/07/24 04:30 AM]