BETA

28th June 2024

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [28/06/24 04:39 PM] with 'Partial Outage'

Issue has been resolved at [28/06/24 04:45 PM]