BETA

25th June 2024

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [25/06/24 10:55 AM] with 'Partial Outage'

Issue has been resolved at [25/06/24 12:31 PM]