BETA

3rd June 2023

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [03/06/23 01:27 AM] with 'Partial Outage'

Issue has been resolved at [03/06/23 01:50 AM]