BETA

29th May 2023

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [29/05/23 03:55 AM] with 'Partial Outage'

Issue has been resolved at [29/05/23 04:06 AM]