BETA

28th May 2023

Delhi Issue observed for 'Incoming Calls' in Delhi Region

Identified at [28/05/23 12:45 AM] with 'Partial Outage'

Issue has been resolved at [28/05/23 12:50 AM]