BETA

26th May 2023

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [26/05/23 09:20 AM] with 'Major Outage'

Issue has been resolved at [26/05/23 09:30 AM]