BETA

25th May 2023

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [25/05/23 02:15 PM] with 'Major Outage'

Issue has been resolved at [25/05/23 02:51 PM]