BETA

25th May 2023

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [25/05/23 01:06 AM] with 'Partial Outage'

Issue has been resolved at [25/05/23 01:10 AM]