BETA

24th May 2023

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [24/05/23 03:56 PM] with 'Major Outage'

Issue has been resolved at [24/05/23 05:55 PM]