BETA

23rd May 2023

Gujarat Issue observed for 'Incoming Calls' in Gujarat Region

Identified at [23/05/23 05:10 PM] with 'Partial Outage'

Issue has been resolved at [23/05/23 05:20 PM]