BETA

30th March 2023

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [30/03/23 11:50 PM] with 'Partial Outage'

Issue has been resolved at [31/03/23 12:30 AM]