BETA

27th March 2023

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [27/03/23 08:51 AM] with 'Major Outage'

Issue has been resolved at [27/03/23 09:25 AM]