BETA

27th March 2023

West Bengal Issue observed for 'Incoming Calls' in West Bengal Region

Identified at [27/03/23 08:45 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [27/03/23 09:20 AM]