BETA

23rd March 2023

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [23/03/23 02:45 PM] with 'Partial Outage'

Issue has been resolved at [23/03/23 02:50 PM]