BETA

19th March 2023

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [19/03/23 01:45 AM] with 'Major Outage'

Issue has been resolved at [19/03/23 01:50 AM]