BETA

18th March 2023

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [18/03/23 01:26 AM] with 'Major Outage'

Issue has been resolved at [18/03/23 01:31 AM]