BETA

13th March 2023

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [13/03/23 02:31 PM] with 'Major Outage'

Issue has been resolved at [13/03/23 03:21 PM]