BETA

17th February 2023

Gujarat Issue observed for 'Outgoing Calls' in Gujarat Region

Identified at [17/02/23 11:05 AM] with 'Partial Outage'

Issue has been resolved at [17/02/23 12:10 PM]