Exotel Status Board
Home
Dashboard
BETA
14th February 2023
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [14/02/23 01:45 AM] with 'Major Outage'
Issue has been resolved at [14/02/23 01:50 AM]