Exotel Status Board
Home
Dashboard
BETA
9th February 2023
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [09/02/23 05:25 PM] with 'Major Outage'
Issue has been resolved at [09/02/23 06:55 PM]