Exotel Status Board
Home
Dashboard
BETA
2nd February 2023
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [02/02/23 03:50 PM] with 'Major Outage'
Issue has been resolved at [02/02/23 03:55 PM]