Exotel Status Board
Home
Dashboard
BETA
1st February 2023
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [01/02/23 01:25 AM] with 'Major Outage'
Issue has been resolved at [01/02/23 01:37 AM]