Exotel Status Board
Home
Dashboard
BETA
31st January 2023
Rajasthan
Issue observed for 'Incoming Calls' in Rajasthan Region
Identified at [31/01/23 02:20 AM] with 'Major Outage'
Issue has been resolved at [31/01/23 02:25 AM]