Exotel Status Board
Home
Dashboard
BETA
20th January 2023
Chennai
Issue observed for 'Incoming Calls' in Chennai Region
Identified at [20/01/23 02:20 AM] with 'Major Outage'
Issue has been resolved at [20/01/23 02:35 AM]