Exotel Status Board
Home
Dashboard
BETA
18th January 2023
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [18/01/23 04:55 PM] with 'Major Outage'
Issue has been resolved at [18/01/23 05:05 PM]