Exotel Status Board
Home
Dashboard
BETA
12th January 2023
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [12/01/23 09:40 PM] with 'Major Outage'
Issue has been resolved at [12/01/23 09:45 PM]