BETA

12th July 2022

Madhya Pradesh Issue observed for 'Outgoing Calls' in Madhya Pradesh Region

Identified at [12/07/22 11:40 AM] with 'Partial Outage'

Issue has been resolved at [12/07/22 11:54 AM]