BETA

3rd July 2022

Kerala Issue observed for 'Outgoing Calls' in Kerala Region

Identified at [03/07/22 12:10 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [03/07/22 12:45 AM]