BETA

29th June 2022

Mumbai Issue observed for 'Outgoing Calls' in Mumbai Region

Identified at [29/06/22 06:15 PM] with 'Partial Outage'

Issue has been resolved at [29/06/22 06:20 PM]