BETA

24th June 2022

Indonesia Issue observed for 'Incoming Calls' in Indonesia Country

Identified at [24/06/22 01:10 AM] with 'Major Outage'

We are investigating this issue at priority.

Issue has been resolved at [24/06/22 02:10 AM]