BETA

24th June 2022

Indonesia Issue observed for 'Outgoing Calls' in Indonesia

Identified at [24/06/22 12:55 AM] with 'Partial Outage'

We are investigating this issue at priority.

Issue has been resolved at [24/06/22 02:10 AM]