BETA

20th June 2022

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [20/06/22 02:25 PM] with 'Partial Outage'

Issue has been resolved at [20/06/22 02:35 PM]