BETA

18th June 2022

Mumbai Issue observed for 'Incoming Calls' in Mumbai Region

Identified at [18/06/22 01:45 PM] with 'Partial Outage'

Issue has been resolved at [18/06/22 01:50 PM]