Exotel Status Board
Home
Dashboard
BETA
18th May 2022
Pune
Issue observed for 'Outgoing Calls' in Pune Region
Identified at [18/05/22 01:35 AM] with 'Major Outage'
Issue has been resolved at [18/05/22 01:40 AM]