BETA

13th May 2022

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [13/05/22 12:35 PM] with 'Major Outage'

Issue has been resolved at [13/05/22 12:40 PM]