BETA

10th May 2022

Andhra Pradesh Issue observed for 'Outgoing Calls' in Andhra Pradesh Region

Identified at [10/05/22 12:50 PM] with 'Major Outage'

Issue has been resolved at [10/05/22 12:55 PM]