Exotel Status Board
Home
Dashboard
BETA
6th May 2022
Pune
Issue observed for 'Incoming Calls' in Pune Region
Identified at [06/05/22 11:40 PM] with 'Major Outage'
Issue has been resolved at [07/05/22 12:35 AM]