BETA

24th January 2022

Kerala Issue observed for 'Incoming Calls' in Kerala Region

Identified at [24/01/22 04:10 PM] with 'Partial Outage'

Issue has been resolved at [24/01/22 04:50 PM]