BETA

17th September 2021

Rajasthan Issue observed for 'Outgoing Calls' in Rajasthan Region

Identified at [17/09/21 04:25 PM] with 'Major Outage'

Issue has been resolved at [17/09/21 04:30 PM]